Digital Ocean didn't expand my disk after doing a permanent resize? [SOLVED]

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Digital Ocean didn't expand my disk after doing a permanent resize? [SOLVED]

      Today had to resize my drive on Digital Ocean.. Whenever you try to upgrade ram and cpu you have no problems but with hard disk it's different. This time when I wanted to increase my hard drive everything looked fine. Created a backup, increased and started the server. Digital Ocean showed that everything is correct but it wasn't...

      So... How to fix it?

      First make sure you create a backup in case of a problem.

      Access your console..

      It looks like your partition and filesystem haven't properly resized to the allotted disk size. We do want to warn, as we always do with any changes on your disk, that there are risks involved with this operation. You'll want to make plenty of backups of your Droplet, the data, etc. Our Snapshotting tool is a great place to start. Once you are happy with the data being secure, we're happy to guide you through resolving the disk issue, just follow these steps:

      1. Check current filesystem size of /dev/vda1:
      df -h

      It should look similar to this:

      Source Code

      1. dev 999M 0 999M 0% /dev
      2. run 1003M 368K 1003M 1% /run
      3. /dev/vda3 20G 16G 2.7G 86% /
      4. tmpfs 1003M 0 1003M 0% /dev/shm
      5. tmpfs 1003M 0 1003M 0% /sys/fs/cgroup
      6. tmpfs 1003M 2.3M 1001M 1% /tmp
      7. tmpfs 201M 0 201M 0% /run/user/1000

      2. Grow the primary partition of your Droplet:
      growpart /dev/vda 1

      3. Grow the filesystem on the partition:
      resize2fs /dev/vda1

      4. Re-check the filesystem size to ensure it is filling the disk:

      df -h

      You should now be fully utilizing the space!

      If this didn't help you, you can try to ask here or get into DO support. They usually reply really fast.
      /Enter Your Signature here/